最新消息:yaf表单扩展中新增加了浮点数、日期和集合的校验。php yaf框架扩展实践三——表单

centos6.7下安装最新版本git

Linux 410浏览 1评论

centos下安装git可以简单的使用yum来安装

$ yum install git

这样安装虽然简单,但是版本太旧还是1.7.1的版本,现在git都已经更新到2.9.1版本了。如果需要安装较新的版本。就需要自己编译安装了,其实也不难就几个操作命令。

第一步安装依赖库

$ yum install curl-devel expat-devel gettext-devel openssl-devel zlib-devel
$ yum install  gcc perl-ExtUtils-MakeMaker

第二步卸载旧版git

加入原先有用yum安装过git,则需要先卸载一下

$ yum remove git

第三步下载源码

$ cd /usr/src
$ wget -O git.zip https://github.com/git/git/archive/master.zip
$ unzip git.zip
$ cd git-master/

这里直接从master分支下载,所以能直接下载最新的,如果要指定版本则需要到其版本库中找对应的tag了。

第四步编译和安装

$ make prefix=/usr/local/git all
$ make prefix=/usr/local/git install

第五步将git目录加入PATH

$ echo 'export PATH=$PATH:/usr/local/git/bin' >> /etc/bashrc
$  or
$ echo 'export PATH=$PATH:/usr/local/git/bin' > /etc/profile.d/git.sh
$ 
$ source /etc/bashrc

安装成功后就可以查看到git版本了。

$ git --version 
git version 2.9.0.GIT

碰到的问题

执行git的时候碰到:

error while loading shared libraries: libiconv.so.2: cannot open shared object file: No such file or directory

到/usr/local/lib目录下查找有这个库。

$ ll /usr/local/lib/libiconv.so.2
lrwxrwxrwx 1 root root 17 Feb 16 09:17 /usr/local/lib/libiconv.so.2 -> libiconv.so.2.5.1

解决办法:

在/etc/ld.so.conf中加一行/usr/local/lib,
然后运行/sbin/ldconfig

转载请注明:快乐编程 » centos6.7下安装最新版本git

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

网友最新评论 (1)

  1. centos yum就是软件版本太低。
    不同凡响10个月前 (08-12)回复